UPS Service temporarily unavailable
Updated
Mar 9, 2026 at 12:20pm UTC
Work is underway to restore the UPS Service following the outage affecting our infrastructure partner in the Middle East region.
We are monitoring recovery efforts and will share further updates as they become available.
Affected services
Created
Mar 1, 2026 at 12:51pm UTC
UPS Service is currently unavailable due to an outage affecting one of our infrastructure partners in the Middle East region after a missile strike impacted the data center facility, resulting in the site being taken offline.
We are monitoring the situation and working with the partner as recovery efforts continue.
Further updates will be provided as more information becomes available.
Affected services