UPS Service Records maintenance
Resolved
Feb 2, 2026 at 3:33pm UTC
The scheduled maintenance on the UPS Service Records system has been successfully completed.
All services are fully operational and performing as expected.
Affected services
Updated
Feb 2, 2026 at 12:47pm UTC
The scheduled maintenance on the UPS Service Records system is still in progress.
The service remains available during this period. Some users may experience intermittent performance variations or brief delays while work continues.
No action is required from users at this time. Additional updates will be provided as needed.
Affected services
Created
Jan 29, 2026 at 12:00pm UTC
We are performing scheduled maintenance on the UPS Service Records system, including platform upgrades and the rollout of new features.
The service will remain available during the maintenance window. Some users may experience slower response times or brief delays while the work is in progress.
No action is required from users. We will provide updates if needed.
Affected services